Welcome to Global Media Online Customer Service

You can enter your question below to search our knowledgebase for an answer or more information now, or submit a Support Ticket directly to our customer service department.

We will respond to all tickets within 24 hours.


Knowledgebase
I can't login to the student forum - it asks for a username and password and mine doesn't work
Posted on 08 August 2011 12:10 AM

Normally you should never have to enter a password or username to get into the student forum - you would login to the course, then click on student forum and the login happens automatically behind the scenes.

If for any reason this doesn't work, you should be able to click on the "My Courses" link at the top of the screen, click on the course again, then click to enter the student forum and everything is reset properly. 

The reason we don't use your normal username for the student forum is that the forum system requires a separate username for each forum - that is, each class you register for. Also, your forum username is visible to other students in the forum if you post, and we were concerned about privacy issues in that regard. When you register for a course, your username is pre-assigned since the system needs a unique username for each course you take. For instance, if your name is Steve Jones, your forum username could be someting like Steve249. If you registered for another class, your username for the forum for that second class could be something like Steve264. In each case, the password is the same as the password you signed up for the course under. But again, normally you should never have to enter this info as the login process should be automatically done behind the scenes.

If for any reason you're seeing a separate login screen for the student forum, please create a Support Ticket and let us know what's going on and we'll be happy to help you.


© Global Media Online, Inc.
Terms of Use          Privacy Policy          Help Desk Software by Kayako globalmedia.kayako.com